ForceBindIP And Windows 10

Discussion in 'Network and Internet' started by MustardLover, May 2, 2018.

  1. MustardLover

    MustardLover New Member

    Joined:
    May 2, 2018
    Messages:
    1
    Trophy Points:
    1
    Ratings:
    +0 / 0 / -0
    Hello,
    I tried, retried and informed myself well before coming here in search of tech-aid, thank you in advance for the help!

    CONFIGURATION
    Windows 10
    Network Interface #1 LAN Realtek Device
    Network Interface #2 Huawei E3372 LTE Surfstick

    My goal obviously is to setup ForceBindIP so that I can browse, let's say, Firefox using NetworkInterface#2 while keeping active and using the NetworkInterface#1 for everything else.

    PROBLEM
    I've tried all possible way to use ForceBindIP, such as:
    - the standalone cmd launcher (I'm on x64 windows and yes I have put files into System32 folder)
    - every GUI available
    - different browsers, no difference

    Windows just ignore the binding passed through cmd and uses the network he finds most efficient, in my case the NI#1 LAN: when I check with IPburger.com I'm always connected with my static LAN IP.

    Here my "route table" situation per route print command on cmd:

    [​IMG]

    :watching: I've read the article
    https://www.raymond.cc/blog/choosing-which-connection-to-use-with-windows-routing-table-editor-gui/

    and it's my understanding that the metrics (35 and 75) in the image above are assigned by windows automatically.
    Other than this I found no useful information, for my case, in the article.
    In fact I modified the metric parameters of my devices, just to try and see if it would change anything.

    - on NI#1 I've set metric 2 via costum interface
    - on NI#2 I've set metric 1 via costum interface

    basically inverting the windows order and giving priority to my LTE USB dongle.
    All worked accordingly after disabling and renabling the two network interfaces, all the internet browsers used the NI#2 by default.
    Still it was impossible for the ForceBindIP command to override this setting, I couldn't reroute any browser over the NI#1 LAN connection.

    :watching: I've read and tried with the 3 GUI showed in the article
    https://www.raymond.cc/blog/bind-wi...work-adapter-with-forcebindip/#comment-470583

    no positive result, the command line is executed by the gui without error and the selected browser is launched but still the network binding is not happening.

    :watching: Also I've tested that the problem isn't related in the use of the IP number instead of the adapter name GUID or vice-versa, when defining the network interface to bind in the command line.
    - I've tried calling by the static IP of my LAN provider and calling the GUID of the LAN adapter (retrived on the app AdapterWatch, with upper case letters
    - I've tried calling by the GUID of the NI#2
    - Also I checked what was the actual IP for the current session of the LTE Network (NI#2), since it's a dynamic assignment, and tried calling by this IP to see if it was the problem


    None of these methods worked, the ForceBindIP couldn't override the windows metric: now I'm really out of ideas...

    Could it be some setting in my router that is forcing things on the various operative systems in my house?
    Yes, I've tried on multiple devices, everyone running Windows 10.

    Thank you for any help you can throw at me :(
    (if I wasn't clear on some points just ask away!)
     

Share This Page...