MMC could not create the snap-in

Discussion in 'General Computer Chat' started by Veronem, Jan 27, 2009.

  1. tangomouse
    Offline

    tangomouse Experienced Member

    Joined:
    Jun 8, 2008
    Messages:
    1,091
    Trophy Points:
    106
    Ratings:
    +0 / 0 / -0
    that admin pack claims to fix snap-in probs ,but after reading it again it does say run as administrator ,maybe that will help

    try this http://support.microsoft.com/kb/826282

    To resolve this behavior, add the %SystemRoot%\System32\WBEM folder to your PATH environment variable. To do so, follow these steps:
    1. Right-click My Computer, and then click Properties.
    2. On the Advanced tab, click Environment Variables.
    3. Under System Variables double-click the PATH environment variable.
    4. Type: %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\system32\WBEM
      Note If other system variables appear, do not remove them.
    5. Click OK, and then click OK.
    Last edited: Jan 27, 2009
  2. Guest Ads
    Online

    Google King of the Internet

  3. heart reaper
    Offline

    heart reaper Experienced Member

    Joined:
    Aug 13, 2008
    Messages:
    1,338
    Trophy Points:
    106
    Ratings:
    +0 / 0 / -0
    Chk this link, they have some solutions there:
    http://social.technet.microsoft.com/Forums/en-US/configmgradminconsole/thread/d97e2f10-8e7e-485d-912c-5292fbec1817/

    Or, Try this,
    Code:
    1. Please run the following command and test again: 
    sfc /purgecache 
    sfc /scannow 
    2. If the problem persists, please follow the steps below: 
    3. Click Start, select RUN and type servermanager.msc, this will open the 
    server manager console. 
    4. If the snap-in cannot be created, please check the error message and 
    write down the GUID. It's in the form of { xxx-xxx-xxx-xxx-xxx} 
    5. Please searched for this CLSID in the Registry HKEY_CLASSES_ROOT\CLSID. 
    To do so, open the registry and expand to 
    "HKEY_CLASSES_ROOT\CLSID\{ xxx-xxx-xxx-xxx-xxx}\InprocServer32 
    6. On the right pane, checked the Default key. It will be something like 
    C:\WINDOWS\system32\filename.dll. Please ensure that the file is present in 
    this location "C:\WINDOWS\system32\filename.dll" 
    7. Please register this dll from cmd prompt: 
    regsvr32 filename.dll 
    8. Close and reopen the MMC 
    9. For any other snap-ins, please repeat step 3 to 8
    If it Still persists, Google, "mmc cannot create the snap in" without quotes. You will get lots of solutions there.
    Last edited: Jan 28, 2009
  4. Veronem
    Offline

    Veronem Regular Member

    Joined:
    Jan 8, 2009
    Messages:
    54
    Trophy Points:
    16
    Ratings:
    +0 / 0 / -0
    finallyyyyyyyy it worked!!!

    thanks guys!

    this is the solution:
    To resolve this behavior, add the %SystemRoot%\System32\WBEM folder to your PATH environment variable. To do so, follow these steps:

    1. Right-click My Computer, and then click Properties.
    2. On the Advanced tab, click Environment Variables.
    3. Under System Variables double-click the PATH environment variable.
    4. Type:
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\system32\WBEM
    Note If other system variables appear, do not remove them.
    5. Click OK, and then click OK.
  5. tangomouse
    Offline

    tangomouse Experienced Member

    Joined:
    Jun 8, 2008
    Messages:
    1,091
    Trophy Points:
    106
    Ratings:
    +0 / 0 / -0
    glad your problem is sorted, happy to help!
  6. mahajanakhil
    Offline

    mahajanakhil New Member

    Joined:
    Aug 2, 2009
    Messages:
    1
    Trophy Points:
    1
    Ratings:
    +0 / 0 / -0
    I found this solution on some other forum.

    Set the path variable in system properties with the following value:

    my computer->properties->advanced->environment settings->system variables

    Name: Path

    Value: %SystemRoot%\System32\WBEM
  7. unRheal
    Offline

    unRheal New Member

    Joined:
    Nov 18, 2009
    Messages:
    1
    Trophy Points:
    1
    Ratings:
    +0 / 0 / -0
    mahajanakhil: That is exactly what Veronem suggested in the 2nd message before yours, and tangomouse 2 before that one! ;)

    Veronem & tangomouse (and mahajanakhil for trying): THANKS! Searching for a fix for this as well brought up this thread, and finally - the solution to this annoying issue! Cheers to all who helped as well!